Page 6 of 6

Re: My R2D2 astromech droid build diary

PostPosted: Mon Jan 14, 2019 9:04 pm
by royjess
Well done, I'm pleased to hear that your's have come to life without any issues :clap: :clap: :clap:

Re: My R2D2 astromech droid build diary

PostPosted: Sat Jan 26, 2019 11:52 pm
by R2D2
I've been building the Deagostini R2D2 for a friend although I haven't done a build diary as he supplied me with all the parts and issues at one go. However. Its now finished but I turned it on and nothing! No lights or sounds and no movement. I've checked the wiring and all seems OK. The batteries are fully charged and register around or over 4.5 volts. Can anyone suggest what I can do! Or mabey you had this problem Corel!

Re: My R2D2 astromech droid build diary

PostPosted: Sun Jan 27, 2019 3:06 pm
by corelki2005
Some things to try/check

1. The batteries are of button top unprotected type and that they are all making good contact in the battery box

2. You did the 2sec battery initialisation procedure

3. after turning on underneath you did press the bottom switch of the bank of 6.

4. double check that all plugs are fully home and the correct way in their sockets

if it still does not start post your problem on the modelspace forum as they will be able to do a better troubleshooting diagnosis than myself

I personally did not have any problems when I completed mine


Nick

Re: My R2D2 astromech droid build diary

PostPosted: Sun Jan 27, 2019 3:30 pm
by R2D2
Thanks or the info. I will try them all.